sys-fs/ksmbd-tools: bump

Now I upstreamed the fixes, bump and remove patches

Package-Manager: Portage-3.0.28, Repoman-3.0.3
Signed-off-by: Guillaume Castagnino <casta@xwing.info>
This commit is contained in:
Guillaume Castagnino 2021-11-05 09:42:00 +01:00
parent 7be835ffa8
commit 1c46cc32f5
Signed by: casta
GPG Key ID: C47D4BFADB084424
4 changed files with 7 additions and 78 deletions

View File

@ -1,5 +1,3 @@
AUX ksmbd-tools-fix-control-return-code.patch 1398 BLAKE2B 27167953e0fc017ae9e52935cee9685bc006d13ee9597aa0566ba4c7ae5e659cf5f73b5ec11cf16ff6d08078be55e2d67c579bb2430bcce55c7d7dceeae39090 SHA512 fbd37952407e5ec218b261f69c8976c2e25d6def7fb4f0ce06ea4983d0b77a7ee3628d21503e63601085f3a8ec3004a9d02bdb729ade562b54fdb58ac1141438
AUX ksmbd.service 407 BLAKE2B 833b00b1dff4671ac64af7e7c4bd13a5edb3ae1deaa31ec08cdff1db65dca9ea70b21acfb501b019b12ad93804d39de45ec1bd360ee0004bce8bc226f5ffe81c SHA512 17ae5eae7d4adbbeefab66677889fb4e6cb6b3ab9cddc048d59166e6541780f6006ec00e09d86ae027dee70e81fd876e86686e36c8c7513896667d5c2664c415
DIST a1144518d74a26e0a45c0c1685f56f0f695bb497.zip 110359 BLAKE2B 29ec05e01c4f6c280793b3ef3e6d11e033cab5c3b39fdf3365a9f3d3c02ea56ff4ccb5cbaac14cb17508fac2a5f954b825e5d9566af9189569801bc4b5c03caf SHA512 9d885c1084991798aea33855f58ebd261b22d46514e1cd25cbf434828d8ca108d0097693034364558daea4fd96c48dbf64f1422d3449e00f0f125b65592a3a23
EBUILD ksmbd-tools-3.4.2_p20211026-r2.ebuild 1054 BLAKE2B d63b57202db385fc6a46f9fbe0388c852932e15255e76dcde3b06cd8258994fab01667ae54706b5521919afb13d263465587d0235ae40a4ccd2f0e3ba0039dc5 SHA512 fd767eee75f06bf00c4351fb4efd82dd156abf05889cfc68300e843e72a45ba5ef9b44bc8bdc4ce3b7ef719fa9c085355897c3e3aac812465a7710ee3625cc52
DIST ksmbd-tools-3.4.2_p20211105.zip 110390 BLAKE2B 741f28160a49bed2beb44252843d4ace1ae461e062e882a1ee51a999552710608aa1ea5bb5fc8cf89a32807c6b189af59a6154275c6d29b50895aa85cbfa9e41 SHA512 44065bcc3c258035c91e769b6cb03a206203e7bbfbe09dc604ab5178a9346a7ed5b45ae2c9a43f0129846fe326cadc89c1e905505d2e9bfc5a19282224a7ab1a
EBUILD ksmbd-tools-3.4.2_p20211105.ebuild 1060 BLAKE2B b3c56e93f3d61ef4c84aac3383a953d8dfa4fddbab6e962aec53b77c2c937a35057aba6555f3a4a940a32d463cc7f70ab0b3e27f9af39144ba3f6a5dbb9e3a3f SHA512 ac4bb05333ea3ddc933772442d23833f46f589e6f3d6477b14a2b02678c5e2b8b3bff3dcb625d4e0a776ea2866e8b96d6232c774685183d03779cfa6cb11ef5a
MISC metadata.xml 253 BLAKE2B ac50d70479526513b1c60d14e609cc24c0498bc5124837f8d20b5d5989cc3876c3e4878ac177658f4be088dd5731142eaefff3ec5aac963efe756eabc5ed26c1 SHA512 96696bc7a2e0f4c1447a44241c7aec867015c37f73f958b72b8489a5038b551f1700dc5540651129a19ab29ce58c4be88bea1226f31b846fb285a25ba4cd61e9

View File

@ -1,49 +0,0 @@
commit 0905c42d80152a28005cd132c19197bf579cada8
Author: Guillaume Castagnino <guillaume.castagnino@rohde-schwarz.com>
Date: Wed Nov 3 11:16:05 2021 +0100
Standardize exit codes
In case of success, EXIT_SUCCESS must be returned by the control binary
This standard behaviour is expected for example for the unit file
diff --git a/control/control.c b/control/control.c
index 5b86355..5ff2780 100644
--- a/control/control.c
+++ b/control/control.c
@@ -43,7 +43,7 @@ static int ksmbd_control_shutdown(void)
ret = write(fd, "hard", 4);
close(fd);
- return ret;
+ return ret != -1 ? EXIT_SUCCESS : EXIT_FAILURE;
}
static int ksmbd_control_show_version(void)
@@ -61,7 +61,7 @@ static int ksmbd_control_show_version(void)
close(fd);
if (ret != -1)
pr_info("ksmbd version : %s\n", ver);
- return ret;
+ return ret != -1 ? EXIT_SUCCESS : EXIT_FAILURE;
}
static int ksmbd_control_debug(char *comp)
@@ -85,7 +85,7 @@ static int ksmbd_control_debug(char *comp)
pr_info("%s\n", buf);
out:
close(fd);
- return ret;
+ return ret != -1 ? EXIT_SUCCESS : EXIT_FAILURE;
}
int main(int argc, char *argv[])
@@ -104,7 +104,7 @@ int main(int argc, char *argv[])
while ((c = getopt(argc, argv, "sd:cVh")) != EOF)
switch (c) {
case 's':
- ksmbd_control_shutdown();
+ ret = ksmbd_control_shutdown();
break;
case 'd':
ret = ksmbd_control_debug(optarg);

View File

@ -1,17 +0,0 @@
[Unit]
Description=ksmbd userspace daemon
Wants=network-online.target
After=network.target network-online.target
[Service]
Type=oneshot
User=root
Group=root
RemainAfterExit=yes
ExecStartPre=-/usr/sbin/modprobe ksmbd
ExecStart=/usr/sbin/ksmbd.mountd -s
ExecReload=/bin/sh -c '/usr/sbin/ksmbd.control -s && /usr/sbin/ksmbd.mountd -s'
ExecStop=/usr/sbin/ksmbd.control -s
[Install]
WantedBy=multi-user.target

View File

@ -8,9 +8,9 @@ inherit autotools systemd
DESCRIPTION="cifsd kernel server userspace utilities"
HOMEPAGE="https://github.com/cifsd-team/ksmbd-tools"
#SRC_URI="https://github.com/cifsd-team/${PN}/releases/download/${PV}/${P}.tgz"
# for now, use a snapshot to have the unit file
HASH=a1144518d74a26e0a45c0c1685f56f0f695bb497
SRC_URI="https://github.com/cifsd-team/${PN}/archive/${HASH}.zip"
# for now, use a snapshot to have the unit file and last fixes
HASH=24df05ea26852fcf349647af2ef642112fceafba
SRC_URI="https://github.com/cifsd-team/${PN}/archive/${HASH}.zip -> ${P}.zip"
LICENSE="GPL-2"
SLOT="0"
@ -27,10 +27,6 @@ BDEPEND=""
S="${WORKDIR}/${PN}-${HASH}"
PATCHES=(
"${FILESDIR}/${PN}-fix-control-return-code.patch"
)
src_prepare() {
default
@ -50,5 +46,6 @@ src_install() {
einstalldocs
dodoc smb.conf.example Documentation/configuration.txt
systemd_dounit "${FILESDIR}/ksmbd.service"
sed -i -e "s:/sbin:${EPREFIX}/usr/sbin:g" ksmbd.service
systemd_dounit ksmbd.service
}